Results 1 to 2 of 2

Thread: Can't Draw Lines

  1. #1
    Join Date
    Feb 2021

    Can't Draw Lines

    I've been using 2004 for about 10 years. I can operate the software on a functional basis, but I'm far from an expert. I only use it to make 2D drawings that are used to show a client a concept or to draw parts that are cut on our plasma table. I may use it for
    a week or two at a time, then not use it again for months. I haven't used the software since November 2020.

    Today, I opened up a drawing to make modifications; the software wouldn't allow me to draw lines. I was able to draw circles, rays and insert text, but no lines. My first thought: a defective file. So, I opened up another file, but I had the same problem.

    I've never used the layers function so I wouldn't even know how to address issues with layers. I've tried starting a new drawing. I've even tried reloading the software. Nothing seems to work. I even did a Google search to no avail. I suspect it may be something simple, but I'm at an impasse. Does anyone have any suggestions?

    Thanks in advance.

  2. #2
    Join Date
    Jan 2008
    English Lake District
    My first thought was to try starting a new drawing, but you say that you have already done that.
    That should exclude it being layers as you would only have layer 0.
    TBH if you can draw circles and text then unless you have changed layers in between it doesn't point to being layer related.

    As you say you have reloaded AutoCad then I suspect it to be something to do with the setup of the general display, so it will be the same for any drawing that you open or start.

    A few things to try:

    After drawing a line try typing- regen or regenall
    That should regenerate the display.

    Try changing the background colour, just in case you may be drawing lines in the same colour as the background. (eg. a white line won't show on a white background).

    Or- Try dragging a crossing selection box (right to left) over the drawing to see if it highlights the line you have just drawn.

    Do you see a 'rubberband' when trying to draw lines?
    The rubberband line color in Acad 2004 is controlled by element named "dynamic dimension line" found in Options > Display > Window Elements > Interface Element.
    Try changing the colour in case it is the same as the background.

    A bit less likely but something else to try:

    Possibly Running Object Snap is on, but with restricted choices so what you draw is 'snapping' on top of existing lines.
    If that is the case you would still see circles or text, but snapped to the existing lines.
    Of course in a new drawing there would be nothing to snap to.
    Try Pressing the F11 key to turn off running object snaps and see if you can draw lines then.

    Do you have the Grid Snap turned on?
    Try typing- snap off

    Both of those snap commands could sometimes end up with the endpoint of the line snapping to the startpoint and just leaving a dot.

    As you say it's probably something simple, but there are that many settings and different ways of doing things in Autocad that even simple problems can be difficult to track down just which setting is causing them.

    Come back and let me know how you get on.
    Last edited by NukeCad; 04-02-2021 at 04:15 AM.
    Im intelligent enough to know that I dont know everything; but I'll tell you all about it anyway.

Similar Threads

  1. Replies: 4
    Last Post: 22-11-2012, 11:20 AM
  2. Draw lines on the userform
    By curial in forum Advanced VBA
    Replies: 2
    Last Post: 22-12-2011, 09:19 AM
  3. Autocad LT2008 Multiple lines [draw partitions]
    By 22oakdene in forum AutoCAD LT Help
    Replies: 1
    Last Post: 12-07-2007, 04:10 PM
  4. draw survey lines
    By teglho in forum Open CAD Discussion
    Replies: 3
    Last Post: 02-06-2005, 02:05 AM
  5. Draw Lines
    By ctlo123 in forum VBA for Beginners
    Replies: 3
    Last Post: 16-11-2004, 08:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts