PDA

View Full Version : How To Create An AutoCAD Template Tutorial



Kevinc
07-09-2015, 05:33 AM
Before we start drawing anything in AutoCAD, we must first set up our very own template. AutoCAD will automatically choose a template for you if you do not specify which template you would like to use. Our template is basically the skeleton of our drawing file, it pretty much tells us everything that will be on the drawing and where it goes.

Templates Include:

(LT) Linetypes
(LIMITS) Drawing Limits
(DDRMODES) Unit Types & Precision
These are just some of the factors templates include…

Now, realistically you don’t want to have to change thAutoCAD Templateese settings every time you open AutoCAD, that’s just a waste of time and a huge pain. So that’s where our templates come in! Once we have a new drawing open, we are going to go ahead and go to File>New and in the templates folder we will choose the file “acad.” We have now loaded the acad template which we can turn into our own personalized template.


Changing Your Drawing Units

To change our units we are going to go to Format>Units (You can also type “units” in the command line at the bottom and the same window will pop up.) Now that we have our units window open, lets take a look at the different options we have.


AutoCAD Template

Length
Type
Precision
Angle
Type
Precision
Remember, there is no “right” way to set up your units, you have to set them up however you need them to be, or however the project you are working on states you to be working in. As a general rule though you should draw at a 1:1 ratio, Being as our work space virtually has no “limit.” If we were drawing on a piece of paper we would of course have to scale it down because we are limited to the size of the paper.

So for the purpose of this lesson we are going to set the Precision to 0.00 and the Insertion Scale to inches. We will now get rid of the USC X & Y, we do that by going to View>Display>UCS Icon>On. If you know the hotkey you can enter “uscicon” in the command line and select off.

Watch on YouTube: Changing Your Drawing Units


Limits

We are now ready to set the limits of the work space. We will set the work space to a normal sized paper. Enter “limits” in the command line and set your lower left corner to 0,0 proceeding to enter 8.5,11 for your upper right hand corner.

To check if you entered it correctly you may hit enter twice, if entered correctly you will see your settings at 8.5,11

Page Setup

Select layout1 then right click layout1 and click on Page Setup Manager.

Setting up Layers

Now that our page is setup, it’s now time to focus on setting up our layers. Organizing your layers makes using AutoCAD 100% faster, organized, and all around better. There is nothing worse than having a lot of information in the work space and have it all mixed up to the point it just becomes and eye sore looking at it.

Click on Layer Properties on the Home Ribbon under the Layers tab. In the upper left hand corner you will see 4 boxes, hover over each one until you find the one that says “New Layer” Create the new layer and name it “Center”. Now we can click on the color tab and select any color you want for your center line, I will choose green. Don’t forget to set the line type to continuous.

Lets make another layer and call it “Dimension.” I’ll set the dimension color to blue and set the line as continuous. The last layer we can make for a basic setup is the “Hidden” line. So repeat the steps as above, I will make my hidden lines red, for line type be sure to select “Hidden.”

Drawing Style

Now it’s time to set up our drawing style, to begin we will type in “st” in the command line. Under Font Name in the drop down menu you can choose whatever font style you like, for the purpose of this lesson we will choose Times New Roman Baltic. For our regular 8.5″ x 11″ paper size we will set our height to .125 (1\8″) Depending on your paper size the height will obviously change to accommodate the size. I’m going to leave the style as standard, once you have the settings all worked in go ahead and hit apply.


OSnaps


For our Osnaps I am going to activate Polar, OSnap, and OTrack.



Creating A Title Block

We will be creating our title block using our layout1 tab.

Print in your layout & always draw in your model space.

On the lower right hand side of your layout1 screen be sure to switch it from model to paper.

We will then enter our command “rec” into the command line to create ourselves a rectangle. We will set the base point at the lower right hand corner and drag upwards to the top left corner leaving a decent amount of space. Type “L” into the command line and select the lower left hand corner of the rectangle. Drag your mouse upwards so it is attached to the 90 degree line and type .5 then hit enter. The line you just created is .5″ above the bottom line now. Drag that newly created line all the way to the right at a 90 degree angle until it snaps on to the opposite side of the rectangle.

We will now use the offset command by typing “o” into the command line. If you read the command line it prompts you to enter in a distance, we will enter in 3″. Select the lower left hand side of the rectangle and offset that line 3″ to the right.


We will then repeat the same step, this time we are going to offset the newly created line 1.5″ to the right. Repeat this again choosing the newly created line and offset it to the right 1″. The last offset we will do will be offsetting the newly created line 3.5″ to the right.

Enter “dt” into the command line and select a point in the lower left hand box where you will type your name. (“dt” will ask you to specify the height and length of the text.) Enter “m” into the command line to move your text and center it in the corresponding box.


The following boxes will include

Date
Project
Scale
Next we will type in the command line “vports”

Select “Single” and click “Ok”

Click the lower right hand corner of the box and drag upwards to the top left corner of the box and select the corner and click. To activate the viewport double click inside the newly created rectangle, to deactivate it double click anywhere outside of the rectangle.

Saving

It’s finally time to save all the hard work we just did. Head to File>Save As


We will be saving this as a .dwt file, .dwt files are AutoCAD’s template file types. So in the drop down menu select the .dwt file type. You can then name the template whatever you desire.

Original Post: http://campcad.com/autocad-template/

NukeCad
07-09-2015, 03:20 PM
I have moved this to the tutorials link forum.

Usual warning, we don't allow advertising in these forums.
As long as your tutorial content is free then no problem.

Kevinc
07-09-2015, 04:34 PM
Thank you!

All the content will remain free!

Kyle Reese
09-09-2015, 12:28 PM
LIMITS is a held-over command that most users have no need or use for.

Why should users preset their text height? What is the benefit? What are the drawbacks?

You have left off quite a bit of detail regarding what the benefits and features are of using OSnaps, Object Snap Tracking and Polar Tracking yet you instruct users to enable these three things. That's like me instructing you about building a deck to use a hammer drill but not telling you what the benefit is over a regular drill nor how to properly use it.

You don't tell users what a viewport is and why one is needed in a layout. Shouldn't viewports also be on their own layer and that layer set to not print?

Spell check.

Kyle Reese
09-09-2015, 04:33 PM
Drawing Style should really be renamed Text Style.

You say "Print in your layout and always draw in model space." I'd change that to: Your title block and border should be placed in paper space while your geometry should be placed in model space. Text and dimensions can be placed in either space. There are pros and cons to each method however. These should be investigated thoroughly and a decision then made as to which suits your particular situation best.

Kevinc
10-09-2015, 04:06 AM
Thanks Kyle,

I really appreciate the input, it helps me become better at trying to explain things and see the points that I miss. As far as the features and benefits of using your OSNAPS etc. I have another post that I go into further detail about them right here (http://campcad.com/autocad-drawing-aids/), I guess I should include a link in that post. Again, I appreciate all your feedback and will relook at my lesson! :)